All Collections
Getting Started
Installing Tali
What are the system requirements to download Tali?
What are the system requirements to download Tali?
Stephanie Mahallati avatar
Written by Stephanie Mahallati
Updated over a week ago

Browser

We recommend using Tali with the latest version of Chrome.

Mac

Operating System: Mac OS X 10.9 Mavericks (Cabernet) or higher

List of all Mac Operating Systems can be found here

Windows

Operating System: Windows 7 (version 6.1) or higher

List of all Windows Operating Systems can be found here

Processors:

  • Supported: x86-based processor (32-bit), x64-based processor (64-bit)

  • Not Supported: ARM-based processor

How to check your process can be found here

iPhone

Operating System: Requires iOS 12.4 or later

iPad

Not officially supported.

Android Phone

Operating system: Android 5 (Lollipop)

Android Tablet

Not officially supported.

Did this answer your question?